[OpenSIPS-Users] Error opening OpenSIPS's FIFO /tmp/opensips_fifo

Jerry Richards jerry.richards at teotech.com
Mon Feb 20 19:46:57 CET 2012

By the way, one more source of this error is if opensips is not running.  So after entering command "./opensips start", check the /var/log/messages file to see if there were any errors.  If there were, then the " ./opensipsctl moni" command will complain it can't open  /tmp/opensips_fifo, while the real reason is that opensips is not running (this is the same thing Flavio was saying using different terminology).


-----Original Message-----
From: Jerry Richards 
Sent: Wednesday, February 15, 2012 10:03 AM
To: 'users at lists.opensips.org'
Subject: Error opening OpenSIPS's FIFO /tmp/opensips_fifo

Hi Flavio,

I found I had two issues, so I am documenting it here so as to help others who might encounter this:

1) After executing the "service postgresql status" command, I found that the postgresql
     service was not running.  The contents of the /var/lib/pgsql/data/pg_log/postgresql-
     Wed.log file indicated a line of the /var/lib/pgsql/data/pg_hba.conf file was in error.
     So I fixed it such that the postgresql service started properly.
2) After resolving the first issue (above), I still was getting the same error when executing
     the "./opensipsctl moni" command.  So, as you suggested, I executed
     "tail /var/log/messages" and found that it needed the following line added to the
     end of the /var/lib/pgsql/data/pg_hba.conf file:
     host   opensips   opensips   trust

Now I no longer get that error.


More information about the Users mailing list